Welcome to the Gamebase 64 forums.                 An attempt to document ALL Commodore 64 gameware before it's too late!

Problem under Linux/Wine

Discuss GameBase, the Universal Emulator Frontend!

Moderator: Jimbo

jice
New Member
Posts: 2
Joined: Sat Mar 09, 2019 11:03 am

Problem under Linux/Wine

Sat Mar 09, 2019 11:10 am

Hello
I'm using the gamebase (great software by the way!) under Linux/Wine.
In particular this one: http://www.gamebase64.com/forum/viewtopic.php?t=5034
Just one problem: when simulating key presses, the \ (backslash) character is not taken into account.
When the frontend sends keys to the emulator in order to open a file, the following appears in the dialog box:
c:gbgames0game.k7
instead of:
c:\gbgames\0\game.k7
Then of course the file is not found by the emulator.
Is it a known problem, and is there a workaround?
Thanks
JC
User avatar
.mad.
Respected Member
Respected Member
Location: Lancashire
Posts: 1889
Joined: Sun Jun 19, 2005 3:30 pm

Re: Problem under Linux/Wine

Sun Mar 10, 2019 11:18 am

Hi,

The problem is not only the system you are using, but the emulator as well.
it doesn't have any command-line to attach the game.

DCexel had a similar problem, but it was possible to edit the BASIC ROM and ini, then sendkeys internally.
I would need to check the Thompson ROM to see if that is possible.

can the backslash be sent typing the path command manually?.
or is it blocked by linux.
Run_Emulator_Send_Keys([2]{ALT}{DOWN}{Enter}[1]c:\gbgame\0\game.k7{Enter}[1]run{C34}{enter}||50)

if so this might work.
* only if the gbgame path is set and files are zipped.
Run_Emulator_Send_Keys([2]{ALT}{DOWN}{Enter}[1]c:\gbgame\0\%gamefile%{Enter}[1]run{C34}{enter}||50)

-
only other solution is to load manually.
open the emu window and wait for you to click on the file to attach...
Run_Emulator_Send_Keys([2]{ALT}{DOWN}{Enter}[1]{enter}||50)
then type
RUN"

edit: just tested an edited version of the mo5 emulator.
managed to get it working the same way as Exelvision. So it will boot the emulator with the gamefile already attached.


will upload a test soon.
User avatar
.mad.
Respected Member
Respected Member
Location: Lancashire
Posts: 1889
Joined: Sun Jun 19, 2005 3:30 pm

Re: Problem under Linux/Wine

Tue Mar 12, 2019 9:27 am

Emulator and script has been fixed.
It should work on any system.

Link in Thomson thread.
jice
New Member
Posts: 2
Joined: Sat Mar 09, 2019 11:03 am

Re: Problem under Linux/Wine

Wed Mar 13, 2019 6:50 pm

Thanks, I gonna test.
Note: tested modifying the script: the backlash key is not transmitted under linux/Wine
User avatar
.mad.
Respected Member
Respected Member
Location: Lancashire
Posts: 1889
Joined: Sun Jun 19, 2005 3:30 pm

Re: Problem under Linux/Wine

Fri Mar 15, 2019 4:54 pm

If the new version script doesn't work on Linux due to the path backslash.

This can be easily fixed if you manually link a game file in the rezip folder and tell me what Linux stores in the dcmoto.ini as the gamepath. :wink:
I153_Chaika
New Member
Posts: 3
Joined: Sun Apr 21, 2019 1:33 pm

Re: Problem under Linux/Wine

Mon May 27, 2019 3:18 pm

I ran into a similar issue, and can confirm that manually rewriting the link does work!

Return to “The GameBase Frontend”

Who is online

Users browsing this forum: No registered users and 5 guests